نوشته های یک برنامه نویس

بلاگ شخصی فرید صباحی مقدم

نوشته های یک برنامه نویس

بلاگ شخصی فرید صباحی مقدم

ویژگی FastTrack در میکروتیک

پنجشنبه, ۱۱ تیر ۱۳۹۴، ۰۵:۲۵ ب.ظ

سلام 

نسخه 6.29 سیستم عامل میکروتیک (هفتم خرداد ماه سال 94) منتشر شد  .

می توانید گزینه Check for Updates را تو سیستم عامل خودتون انتخاب کنید و سیستم عامل رو به آخرین نسخه یعنی 6.29 به روز زسانی کنند و یا از طریق لینک زیر اون رو دانلود و عملیات به روز رسانی را انجام بدین و از ویژگی های جدیدی مثل FastTrack لذت ببرید .

FastTrack

اما چرا نسخه 6.29 ؟

اصلا این ویژگی FastTrack چی هستش ؟

در ادامه مطلب کاملا بهش اشاره میکنیم ...




طبق نوشته های Changelog تغییرات مورد نظر ما عبارت است از : 

What's new in 6.29 (2015-May-27 11:19) :

- ipv4 fasttrack fastpath - accelerates connection tracking and nat for marked connections (more than 5x performance improvement compared to regular slow path conntrack/nat) - currently limited to TCP/UDP only;


- added ~fasttrack-connection~ firewall action in filter/mangle tables for marking connections as fasttrack;

- added fastpath support for bridge interfaces - packets received and transmitted on bridge interface can go fastpath (previously only bridge forwarded packets could go fastpath);

- packets now can go half-fastpath - if input interface supports fastpath and packet gets forwarded in fastpath but output interface does not support fastpath or has interface queue other than only-hw-queue packet gets converted to slow path only at the dst interface transmit time;

- trafflow: add natted addrs/ports to ipv4 flow info.


البته در زمان نگارش این مقاله نسخه  6.29.1 هم منتشر شده که مشکلاتی از نسخه 6.29 رو رفع کرده ...


یادآوری 

NAT  چیست :

NAT بسیار ساده و کاربردی هستش مثلا که یک کامپیوتر یا مسیریاب به عنوان دروازه ورود به اینترنت عمل می کند .
با این کار آدرس های ایستگاه های کاری را به آدرس دستگاهی که NAT روی آن فعال است تبدیل میکنه ، به بیان ساده تر NAT روی کامپیوتر یا مسیریاب که به اینترنت وصل شده فعال میشه و شبکه و ایستگاه های کاری رو از دید اینترنت پنهان میکنه .

البته دقت کنید که ویژگی NAT تنها جهت استفاده به عنوان دروازه ورود به اینترنت نیست ، بلکه شما از این تکنولوژی میتونید بین شبکه های داخلی خودتون استفاده کنید .



اما دقیقا این Fast Track چی هستش دقیقا ؟

به کمک قابلیت FastTrack می توان سرعت فایروال و سرعت NAT دستگاه ها را تا 5 برابر افزایش داد . 

البته در سناریو های مختلفی هم استفاده میشه مثلا : این ویژگی رو هم میشه جهت mark کردن ترافیک خاصی جهت اضافه کردن رول firewall با استفاده از fasttrack پیاده سازی کرد ، که این حالت چون ترافیک رو پردازش و processing اضافه نمیکنه ، سرعت کار چندین برابر بیشتر میشه .

دقت کنید که Fast Track در حال حاضر فقط بسته های TCP و UDP رو پشتیبانی میکنه .



FastTrack در صورتی فعال میشود که شرایط زیر برقرار باشد :


-   no mesh, metarouter interface configuration
-   sniffer, torch and traffic generator is not running

-   no active mac-ping, mac-telnet or mac-winbox sessions

-   /tool mac-scan is not actively used

-   /tool ip-scan is not actively used




برای مثال کاربران خانگی ، میتونن به سادگی با استفاده از fasttrack همه ترافیک Lan رو با firewall rule منقل کنن .


/ip firewall filter

add chain=forward action=fasttrack-connection connection-state=established,related

add chain=forward action=accept connection-state=established,related


rule دوم لازم است ، برای اینکه fasttrack برخی از ترافیک ها را شناسایی نمیکند ، پس شما باید این رول رو حتما اضافه کنید ، همچنین دقت کنید که اگر قصد انتقال همه ترافیک رو داشته باشید ، این دو rule در بخش firewall باید بالاترین (بر اساس ترتیب) باشند ، در غیر این صورت اگر قصد انتقال کل ترافیک رو نداشتید میتونید تغییرات مورد نظرتون رو اعمل کنید ... 




نتایج راه اندازی این ویژگی در RB2011UiAS-2HnD :

قبل از استفاده   :

• 360Mbps throughput and CPU @100%

• 44% of CPU time was taken by firewall

BefoureFastTrack




بعد از استفاده  :

• 890Mbps throughput and CPU @86%

• 6% of CPU time was taken by firewall

AfterFastTrack




منابع :


www.mikrotik.com

wiki.mikrotik.com


آیا شما از این قابلیت استفاده کرده اید؟ تجربیات خودتون رو در این زمینه در اختیار ما بزارید .


نظرات  (۰)

هیچ نظری هنوز ثبت نشده است

ارسال نظر

ارسال نظر آزاد است، اما اگر قبلا در بیان ثبت نام کرده اید می توانید ابتدا وارد شوید.
شما میتوانید از این تگهای html استفاده کنید:
<b> یا <strong>، <em> یا <i>، <u>، <strike> یا <s>، <sup>، <sub>، <blockquote>، <code>، <pre>، <hr>، <br>، <p>، <a href="" title="">، <span style="">، <div align="">
تجدید کد امنیتی